FC2ブログ

apt-get update ができない場合の対処

先日、ubuntu のアップデートを行おうとしたのですが

アップデートができなくなりました

今回、表示されたエラーは

ロック /var/lib/apt/lists/lock が取得できませんでした

というものです


どうやら、apt-get update がロックされているようです

対処方法を探した結果
apt-getのエラーの対処(ubuntu, debian)
を参考にすることで解決しました

どうやら、apt-get のプロセスが残っていたのが原因でした

ps ax | grep apt
でプロセスを確認し

1917 ? SN 0:00 /bin/sh /etc/cron.daily/apt
1987 ? RN 208:05 apt-get -qq -y update
1990 ? SN 0:00 /usr/lib/apt/methods/http
1991 ? SN 0:00 /usr/lib/apt/methods/http
1992 ? SN 0:00 /usr/lib/apt/methods/http
1993 ? SN 0:00 /usr/lib/apt/methods/http
1994 ? SN 0:00 /usr/lib/apt/methods/http
1995 ? SN 0:00 /usr/lib/apt/methods/http
1996 ? SN 0:00 /usr/lib/apt/methods/cdrom
1999 ? SN 0:00 /usr/lib/apt/methods/gpgv
2009 ? SN 0:00 /usr/lib/apt/methods/bzip2
6819 pts/2 S+ 0:00 grep --color=auto apt

となっているのを確認

一番左の番号がプロセス番号になるので、これを
kill コマンドで消していきます

sudo kill -KILL 1909
というように、管理者権限で、1つずつ消していきました

もしかしたら、正規表現などを用いれば、一期にいけるかもしれませんが

とりあえず、これで無事に apt-get update ができると思ったのですが

もう一つの問題が発生

Ubuntu 10.10 _Maverick Meerkat_ - Release i386
というラベルのついたディスクを/cdrom/ ドライブに挿入してください

というメッセージがでてしまし、アップデートできないと状況が

これに関しては
古いバージョンからのアップデートができません
を参考に、

システム > システム管理 > Syanaptics パッケージマネージャー
を開いて

設定タブ > リポジトリ を開き

なぜかついていた
CDーROM/DVD からのインストールの項目のチェックをはずすことで

無事にアップデート完了となりました

スポンサーサイト



テーマ : Linux
ジャンル : コンピュータ

コメント

非公開コメント

最新記事
検索フォーム
GREEハコニワ攻略サイト
リンク
カテゴリ
月別アーカイブ
フリーエリア
最新記事
FXプライムレート
最新コメント
最新トラックバック